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LAB 12 - Point Controls, Secondary 
Alignments, and Parametric Constraints

This lab demonstrates the use of various controls to modify a template during processing.  It will highlight 
various settings in point controls, illustrate the effects of a secondary alignment, and demonstrate the use of 
parametric constraints.

Chapter Objectives:

 Create a Horizontal Point Control to add an additional lane using offsets.

 Create a Horizontal and Vertical Point Control to add a scab-on detour.

 Create a Horizontal Point Control using a Secondary Alignment.

 Use Parametric Constraints to widen the road surface.

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Preferences\CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES.ird

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

Lab 12.1 - Adding an Additional Lane with Offset Point Controls

In this exercise the corridor created in the previous lab is modified by adding an additional lane to the right side 
of the template using a standard point control.  This control is based on the centerline (SH 86) alignment and 
uses offset distances from this alignment to modify the template.  Three control entries are required to 
complete the transition.

1. Select Modeler > Roadway Designer from InRoads.

2. Verify that the 12345DES corridor is active.

The first point control transitions from two lanes to three lanes. 

3. In the Roadway Designer dialog box, select Corridor > Point Controls from the menu 

bar or <D> the point controls button .

4. In the Point Controls dialog box, select RT_HMA_Lift1_EOP-Top for the point.  Use the 

drop down menu or <D> the “target”  button and then <D> the point in the template 
view to make the selection.

5. Toggle on Horizontal for the Mode.
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6. Set the Horizontal Alignment to SH 86.

7. Key in 220+00.00 in the Station Limits Start field.

8. Key in 222+50.00 in the Station Limits Stop field.

9. Key in 24 in the Horizontal Offsets Start field.

10. Key in 36 in the Horizontal Offsets Stop field.

11. <D>  Add.  The entry is added to the Horizontal and Vertical Controls list.

This creates the beginning transition for the additional lane.

The Point, Mode, Control Type, and Horizontal Alignment stay the same for the two 
remaining entries.  Only the Stations and Offsets change.  the second point control 
maintains the third lane.

12. Key in 222+50.00 in the Station Limits Start field.
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13. Key in 229+00.00 in the Station Limits Stop field.

14. Key in 36.00 in the Horizontal Offsets Start field.

15. Key in 36.00 in the Horizontal Offsets Stop field.

16. <D>  Add.  This entry maintains the full width of the additional lane.

The third point control transitions from three lanes back to two lanes.

17. Key in 229+00.00 in the Station Limits Start field.

18. Key in 231+50.00 in the Station Limits Stop field.

19. Key in 36.00 in the Horizontal Offsets Start field.

20. Key in 24.00 in the Horizontal Offsets Stop field.

21. <D>  Add.  This entry transitions the template back to its normal width.

22. <D> Close to dismiss the Point Controls dialog box.

This series of steps sets the display in the template view to a specific size.  This makes it easier 
to see the transitions occur when scrolling through the stations.

23. <R> in the template view of the Roadway Designer dialog box and select Display 
Properties from the menu.

24. Toggle on Center Backbone.

25. Key in 75% (.75) for the Backbone Screen Width.

26. Select 5 for the Vertical Exaggeration.

27. <D> OK.  This makes the template change easier to see when scrolling through the 
stations.
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28. Scroll through the stations between 220+00.00 and 231+50.00 and notice how the template 
behaves.

29. Select File > Save from the Roadway Designer menu bar.

Lab 12.2 - Creating a Scab-On Detour using Point Controls

In this exercise a scab-on detour is added to the left side of the existing pavement from station 206+00 to 
215+00.  This requires a new corridor, template drop, and two sets of point controls.  One is a horizontal and 
vertical control that follows the existing edge of pavement.  The second is a horizontal offset control that 
transitions the detour to its full width.

1. Select Corridor > Corridor Management from the Roadway Designer menu bar or 

<D> the Manage Corridors button .

2. In the Manage Corridors dialog box, key in Scab-on Detour for the Name.

3. Toggle on the Station Limits.

4. Key in 206+00.00 for the Start station.

5. Key in 215+00.00 for the Stop station.

6. <D> Add.

7. <D> Close.

This corridor could have been built on the edge of pavement feature from the dtm, but by 
using the alignment it will be easier to locate stations.



Colorado Department of Transportation   Page 247

Labs for InRoads XM LAB 12 - Point Controls, Secondary Alignments, and Para-

8. Select Corridor > Template Drops from the Roadway Designer menu bar or <D> the 

Template Drops button 

9. In the Template Drops dialog box, key in 206+00.00 for the Station.

10. Key in 25 for the Interval.

11. Expand the C:\Projects\12345\Design\InRoads\DES12345-Templates.itl >    
1- Templates folder in the Library Templates area and highlight the Scab-on Detour 
template.

12. <D> Add.

13. <D> Close.

The first point control moves the origin of the template from the SH 86 alignment to the left 
edge of pavement feature in the 12345 Existing Ground surface.

14. In the Roadway Designer dialog box, select Corridor > Point Controls from the menu 
bar or <D> the point controls button.

15. In the Point Controls dialog box, select HMA_Lift1_Shoulder-Top for the Point.
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16. Toggle on Both for the Mode.

17. Select Feature for the Control Type.

18. Select T_Traffic Single Solid White386 for the feature (This is the 18th T_Traffic Single 
Solid in the pull down list).

Note: Creating a feature filter will make it easier to locate the desired feature.  The filter 
should Start With None, use the Name Attribute, and have a Value of *386*.  
See the module “Initial Surface Procedures” of the “Practical Guide for InRoads 
XM” for more information in feature filters.

Note: The 12345 existing ground surface is the only dtm loaded so it is selected by 
default.

19. <D> Add.

Notice that the template has moved to approximately 12 feet to the left.  Next, a horizontal 
point control is created that transitions the detour to its full width.  

20. In the Point Controls dialog box, set the Point to LT_HMA_Lift1_EOP-Top.

21. Toggle on Horizontal for the Mode.

22. Set the Control Type to Alignment.

23. Set the Horizontal Alignment to SH 86.

24. In the Station Limits area, key in 206+00.00 for the Start station.

25. Key in 208+50.00 for the Stop station.

26. In the Horizontal Offsets area, key in -11.93 for the Start offset.

27. Key in -24.00 for the Stop offset.
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28. <D> Add.

The Point, Mode, Control Type, and Horizontal Alignment stay the same for the two remaining 
entries.  Only the Stations and Offsets change.  The steps below create a point control that 
maintains the detour’s full width.

29. Key in 208+50.00 in the Station Limits Start field.

30. Key in 212+50.00 in the Station Limits Stop field.

31. Key in -24.00 in the Horizontal Offsets Start field.

32. Key in -24.00 in the Horizontal Offsets Stop field.

33. <D>  Add.  This entry maintains the full width of the additional lane.

The final point control transitions from the full width to the end of the detour.

34. Key in 212+50.00 in the Station Limits Start field.

35. Key in 215+00.00 in the Station Limits Stop field.

36. Key in -24 in the Horizontal Offsets Start field.

37. Key in -12.22 in the Horizontal Offsets Stop field.

Note: The offset distances entered are measured from the specified Horizontal alignment 
and not from the origin of the template.

38. <D>  Add.  

39. <D> Close to dismiss the Point Controls dialog box.

Scroll through the stations and notice how the template behaves.  From station 206+00 to 
station 208+50 the template expands from the existing edge of pavement until it reaches its full 
width.  Then it maintains that width from station 208+50 to station 212+50.  Finally,  it 
contracts back to the pavement edge from station 212+50 to station 215+00.  

40. Select File > Save from the Roadway Designer menu bar.
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Lab 12.3 - Using Horizontal Point Control and a Secondary 
Alignment

Alignments other than the design centerline can be used for horizontal controls.  Typically, they are used to 
modify the width of the template.  They can also be used to change the direction (in relation to the design 
centerline) that the template components are placed.  When an alignment is used in this manner, it is called a 
secondary alignment.  

This exercise uses a secondary alignment to create the beginning of an off ramp.  A new corridor is created 
using the SH 86 alignment.

1. Select Corridor > Corridor Management from the Roadway Designer menu bar or 
<D> the Corridor Management button.

2. In the Manage Corridors dialog box, key in Off Ramp for the Name.

3. Toggle on the Station Limits.

4. Key in 205+00.00 for the Start station.

5. Key in 215+00.00 for the Stop station.

6. <D> Add.

7. <D> Close.

A single template drop is required for this corridor.

8. Select Corridor > Template Drops from the Roadway Designer menu bar or <D> the 
Template Drops button.

9. In the Template Drops dialog box, key in 205+00.00 for the Start station.
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10. Key in 25 for the Interval.

11. Expand the C:\Projects\12345\Design\InRoads\DES12345-Templates.itl >    
1- Templates folder in the Library Templates area and highlight the 
CONC_4Lane_Right-Side_Only template.

12. <D> Add.

13. <D> Close.

A horizontal point control is used to widen the template and reposition its components 
perpendicular to the Off Ramp alignment.

14. In the Roadway Designer dialog box, select Corridor > Point Controls from the menu 
bar or <D> the point controls button.

15. In the Point Controls dialog box, select RT_Conc_Shoulder-Top for the Point.

16. Toggle on Horizontal for the Mode.

17. Select Alignment for the Control Type.

18. Select Off Ramp for the Horizontal Alignment.
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19. In the Station Limits area, key in 205+00.00 for the Start station.

20. Key in 215+00.00 for the Stop station.

21. Make sure the Horizontal Offsets are set to 0.

22. Toggle on Use as Secondary Alignment.

23. <D> Add.

24. <D> Close.

25. Scroll through the stations between 205+00.00 and 215+00.00 and notice how the template 
behaves.  The orange line in the plan view and the template view represents the Off Ramp 
alignment.  Notice how the template line (the yellow line in the plan view) outside the Off 
Ramp alignment changes so that it is perpendicular to the Off Ramp alignment.

26. Select File > Save from the Roadway Designer menu bar.

Lab 12.4 - Using Parametric Constraints to Widen the Road 
Surface

Parametric Constraints are used to modify the value of the constraint.  This option allows greater flexibility of 
what can be modified during processing as slopes and vector/offsets can be modified in addition to the usual 
horizontal and vertical controls.  In this exercise, the Horizontal Constraint of a template point is modified to 
widen the template on the left side.  This is done in a similar maner to the first exercise.
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The corridor used in Lab 6.1 is also used here.

1. In the Roadway Designer dialog box, select 12345DES for the corridor.

2. Select Tools > Parametric Constraints from the Roadway Designer menu bar.

3. In the Parametric Constraints dialog box, select LT_EOP-Top-Horiz for the Constraint 
Label.

4. Key in -36 for the Stop Value (the Start Value stays the same for this entry).

5. In the Station Limits area, key in 237+00.00 for the Start station.

6. Key in 239+50.00 for the Stop station.
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7. <D> Add.

8. Key in -36 for the Start Value (the Stop Value stays at -36).

9. In the Station Limits area, key in 239+50.00 for the Start station.

10. Key in 252+50.00 for the Stop station.

11. <D> Add.

12. Key in -24 for the Stop Value (the Start Value stays at -36).

13. In the Station Limits area, key in 252+50.00 for the Start station.

14. Key in 255+00.00 for the Stop station.

15. <D> Add.

16. <D> Close. This dismisses the Parametric Constraints dialog box.
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17. Scroll through the stations between 237+00.00 and 255+00.00 and notice how the template 
behaves.

18. Select File > Save from the Roadway Designer menu bar.

19. <D> Close to dismiss the Roadway Designer dialog box.

Chapter Summary:

 In Lab 12.1 -Adding an Additional Lane with Offset Point Controls Horizontal Point 
Controls were used to add an additional lane to the design.  The control was based off the 
design centerline with offset distances measured from that alignment. 

 Lab 12.2 -Creating a Scab-On Detour using Point Controls a Horizontal and Vertical Point 
Control was created to locate a template on the edge of the existing pavement.  The edge of 
pavement feature from the existing ground surface was used to locate the template.  A 
horizontal control based off the design centerline was also used to transition the template, 
creating the scab-on detour. 

 In Lab 12.3 -Using Horizontal Point Control and a Secondary Alignment a Horizontal 
Point Control using a Secondary Alignment was created.  By changing the angle of the 
components outside of the secondary alignment, their shape is maintained around curves 
making this option ideal for ramps and street returns.

 Lab 12.4 -Using Parametric Constraints to Widen the Road Surface used Parametric 
Constraints to widen the road surface.  The results were similar to those achieved in the 
first exercise but a different method was used.



Page 256 Colorado Department of Transportation

LAB 12 - Point Controls, Secondary Alignments, and Parametric Constraints Labs for InRoads XM


